Website & Billing System SSL
Incident Report for BeDot Media Group
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 18:10 UTC
Identified
The SSL Certificate on our Website & Billing system has expired, we have renewed it and just awaiting verification. Apologies for the inconvenience. Should you need assistance in the mean time, please email: support@bedot.com
Posted Nov 15, 2022 - 12:02 UTC
This incident affected: Billing System.