Billing System Down

Incident Report for BeDot Media Group

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 19:05 UTC

Identified

We currently have an issue affecting our billing system & corporate email system, Servers are just running checks. We will have this up and running as soon as checks have been completed.
Posted Feb 27, 2025 - 15:52 UTC
This incident affected: Billing System.