Stout Server Down
Incident Report for BeDot Media Group
Resolved
This incident has been resolved.
Posted Apr 13, 2023 - 17:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 13, 2023 - 15:05 UTC
This incident affected: UK Shared Hosting.