Live Chat Offline
Incident Report for BeDot Media Group
Resolved
Issue has now been resolved.
Posted Dec 09, 2022 - 11:33 UTC
Investigating
We are currently investigating an issue with our live chat system, its currently offline any support issues please use the help desk ticket system.
Posted Dec 09, 2022 - 11:14 UTC
This incident affected: Billing System.