Live Chat Down
Incident Report for BeDot Media Group
Resolved
Live Chat is now active
Posted Oct 20, 2022 - 15:03 UTC
Identified
We are currently experiencing a problem with our LIVE Chat client.
Posted Oct 20, 2022 - 14:50 UTC
This incident affected: Billing System.