VM220818 - Server Down
Incident Report for BeDot Media Group
Resolved
This incident has been resolved.
Posted May 18, 2023 - 15:02 UTC
Investigating
Server is currently unreachable, we are investigating the issue.
Posted May 18, 2023 - 14:44 UTC
This incident affected: US Shared Hosting.